WeightStyle Enumeration
Enumeration of how weights are carried
- UnWeighted (0) -- there are no weights
- WeightsAlreadyAppliedToCoordinates (1) -- for real point (x,y,z) the homogeneous point has weight applied throughout as (wx,wy,wz,w)
- WeightsSeparateFromCoordinates (2) -- for real point (x,y,z) the homogeneous point is (x,y,z,w)
- Note that "internal" computations never use WeightsSeparateFromCoordinates.
- WeightsSeparateFromCoordinates is only useful as input or output state in serializer.
Members
Defined in
- bspline/BSplineSurface.ts Line 44
Last Updated: 30 November, 2023