create MethodStatic
Create a weighted bspline surface, with control points and weights each organized as flattened array of points continuing from one U row to the next.
- This
create
variant takes control points in a "flattened" array, with points from succeeding U rows packed together in one array. UsecreateGrid
if the points are in a deeper grid array structure. - knotArrayU and knotArrayV are optional -- uniform knots are implied if they are omitted (undefined).
- When knots are given, two knot count conditions are recognized:
- If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping.
- If poleArray.length + order == knotArray.length + 2, the knots are in modern form that does not have the classic unused first and last knot.
create(controlPointArray: Point3d[] | Float64Array, weightArray: number[] | Float64Array, numPolesU: number, orderU: number, knotArrayU: undefined | number[] | Float64Array, numPolesV: number, orderV: number, knotArrayV: undefined | number[] | Float64Array): undefined | BSplineSurface3dH
Parameter | Type | Description |
---|---|---|
controlPointArray | Point3d[] | Float64Array | Array of points, ordered along the U direction. |
weightArray | number[] | Float64Array | array of weights, ordered along the U direction. |
numPolesU | number | |
orderU | number | order for the U direction polynomial (order is one more than the degree . "cubic" polynomial is order 4.) |
knotArrayU | undefined | number[] | Float64Array | |
numPolesV | number | |
orderV | number | order for the V direction polynomial (order is one more than the degree . "cubic" polynomial is order 4.) |
knotArrayV | undefined | number[] | Float64Array |
Returns - undefined | BSplineSurface3dH
Defined in
- bspline/BSplineSurface.ts Line 835
Last Updated: 30 November, 2023