create MethodStatic
Create a bspline surface.
- This
create
variant takes control points in a "flattened" array, with points from succeeding U rows packed together in one array. UsecreateGrid
if the points are in a row-by-row grid structure - knotArrayU and knotArrayV are optional -- uniform knots are implied if they are omitted (undefined).
- When knots are given, two knot count conditions are recognized:
- If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping.
- If poleArray.length + order == knotArray.length + 2, the knots are in modern form that does not have the classic unused first and last knot.
create(controlPointArray: Point3d[] | Float64Array, numPolesU: number, orderU: number, knotArrayU: undefined | number[] | Float64Array, numPolesV: number, orderV: number, knotArrayV: undefined | number[] | Float64Array): undefined | BSplineSurface3d
Parameter | Type | Description |
---|---|---|
controlPointArray | Point3d[] | Float64Array | Array of points, ordered along the U direction. |
numPolesU | number | |
orderU | number | order for the U direction polynomial (order is one more than the degree . "cubic" polynomial is order 4.) |
knotArrayU | undefined | number[] | Float64Array | |
numPolesV | number | |
orderV | number | order for the V direction polynomial (order is one more than the degree . "cubic" polynomial is order 4.) |
knotArrayV | undefined | number[] | Float64Array |
Returns - undefined | BSplineSurface3d
Defined in
- bspline/BSplineSurface.ts Line 576
Last Updated: 30 November, 2023