createGrid MethodStatic
Create a bspline surface.
- This
create
variant takes control points in a "grid" array, with the points from each grid row[rowIndex]
being an independent arraypoints[rowIndex][indexAlongRow][x,y,z]
- knotArrayU and knotArrayV are optional -- uniform knots are implied if they are omitted (undefined).
- When knots are given, two knot count conditions are recognized:
- If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping.
- If poleArray.length + order == knotArray.length + 2, the knots are in modern form that does not have the classic unused first and last knot.
createGrid(points: number[][][], orderU: number, knotArrayU: undefined | number[] | Float64Array, orderV: number, knotArrayV: undefined | number[] | Float64Array): undefined | BSplineSurface3d
Returns - undefined | BSplineSurface3d
Defined in
- bspline/BSplineSurface.ts Line 633
Last Updated: 30 November, 2023