createThroughPoints MethodStatic
Greville knot algorithm: alternative to traditional c2 cubic algorithm allowing for any order, but no end conditions or periodicity.
createThroughPoints(points: Point3d[] | IndexedXYZCollection, order: number): undefined | BSplineCurve3d
Parameter | Type | Description |
---|---|---|
points | Point3d[] | IndexedXYZCollection | pass-through points. |
order | number | bspline order (1 more than degree) |
Returns - undefined | BSplineCurve3d
Defined in
- bspline/BSplineCurveOps.ts Line 31
Last Updated: 30 November, 2023