createPeriodicUniformKnots MethodStatic
Create a smoothly closed B-spline curve with uniform knots. Note that the curve does not start at the first pole!
createPeriodicUniformKnots(poles: Point3d[] | Float64Array | GrowableXYZArray, order: number): undefined | BSplineCurve3d
Parameter | Type | Description |
---|---|---|
poles | Point3d[] | Float64Array | GrowableXYZArray | |
order | number |
Returns - undefined | BSplineCurve3d
Defined in
- bspline/BSplineCurve.ts Line 446
Last Updated: 30 November, 2023