isAlmostEqual Method
test for exact structure and nearly identical geometry.
- Leaf classes must implement !!!
- base class implementation recurses through children.
- base implementation is complete for classes with children and no properties.
- classes with both children and properties must implement for properties, call super for children.
isAlmostEqual(other: GeometryQuery): boolean
Parameter | Type | Description |
---|---|---|
other | GeometryQuery |
Returns - boolean
Defined in
- bspline/AkimaCurve3d.ts Line 166
Last Updated: 30 November, 2023