Bspline
A bspline curve or surface is used for curved freeform geometry defined by controls points (sometimes called poles).
- BSplineCurve -- a curve defined by control points (which are not on the curve)
- InterpolationCurve -- a curve defined by passthrough points, with "good" visual properties
- BSplineSurfaceXYZ -- a surface with XYZ
- BsplineSurfaceXYZW -- a surface with weighted (rational) XYZ coordinates
- KnotVector -- vector of breakpoints in bspline definitions.
Classes
Name | Description | |
---|---|---|
AkimaCurve3d | Interpolating curve. | |
AkimaCurve3dOptions | fitPoints and end condition data for AkimaCurve3d | |
Bezier1dNd | Shared implementation details for derived bezier curve classes | |
BezierCurve3d | 3d Bezier curve class. | |
BezierCurve3dH | 3d curve with homogeneous weights. | |
BezierCurveBase | Base class for CurvePrimitive (necessarily 3D) with _polygon. | |
BSpline1dNd | Bspline knots and poles for 1d-to-Nd. | |
BSpline2dNd | Bspline knots and poles for 2d-to-Nd. | |
BSplineCurve3d | A BSplineCurve3d is a bspline curve whose poles are Point3d. | |
BSplineCurve3dBase | Base class for BSplineCurve3d and BSplineCurve3dH. | |
BSplineCurveOps | A class with static methods for creating B-spline curves. | |
BSplineSurface3d | BSplineSurface3d is a parametric surface in xyz space. | |
BSplineSurface3dH | BSpline Surface in xyzw homogeneous space | |
InterpolationCurve3d | Interpolating curve. | |
InterpolationCurve3dOptions | fitPoints and end condition data for InterpolationCurve3d | |
KnotVector | Array of non-decreasing numbers acting as a knot array for bsplines. |
Enumerations
Name | Description | |
---|---|---|
BSplineWrapMode | Enumeration of the possible ways of converting a "periodic" knot vector to an open knot vector. | |
UVSelect | UVSelect is an integer indicating uDirection (0) or vDirection (1) in a bspline surface parameterization. | |
WeightStyle | Enumeration of how weights are carried |
Interfaces
Name | Description | |
---|---|---|
AkimaCurve3dProps | fitPoints AkimaCurve3d | |
BSplineSurface3dQuery | Interface for methods supported by both regular (xyz) and weighted (xyzw) bspline surfaces. | |
InterpolationCurve3dProps | fitPoints and end condition data for InterpolationCurve3d | |
PackedPointGrid | interface for points returned from getPointGrid, with annotation of physical and weighting dimensions. |
Namespaces
Name | Description | |
---|---|---|
BSplineCurveOps | Namespace for collecting curve fit API |
Last Updated: 30 November, 2023