uvFractionToPointAndTangents Method
Convert fractional u and v coordinates to surface point and in-surface tangent directions.
- Remark: the vectors are expected to be non-zero tangents which can be crossed to get a normal.
- Hence the are NOT precisely either (a) partial derivatives or (b) frenet vectors
uvFractionToPointAndTangents(uFraction: number, vFraction: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors
Parameter | Type | Description |
---|---|---|
uFraction | number | fractional coordinate in u direction |
vFraction | number | fractional coordinate in the v direction |
result | Plane3dByOriginAndVectors | optional pre-allocated carrier for point and vectors |
Returns - Plane3dByOriginAndVectors
Last Updated: 30 November, 2023