createDefaultView Method
Creates a default ViewState3d based on the model ids passed in. If no model ids are passed in, all 3D models in the iModel are used.
createDefaultView(options?: ViewCreator3dOptions, modelIds?: string[]): Promise<ViewState>
throws IModelError If no 3d models are found in the iModel.
Parameter | Type | Description |
---|---|---|
options | ViewCreator3dOptions | |
modelIds | string[] |
Returns - Promise<ViewState>
Defined in
Last Updated: 30 November, 2023