dispatchImmediateUiSyncEvent Method
Beta
Method used by interactive tools to inform one or more UI components to refresh. This is typically used to update labels or icons associated with a specific tool. This method should be used when the caller wants the UI layer to process the sync event immediately. Use dispatchUiSyncEvent when the event may be triggered while other more important user interaction processing is required.
dispatchImmediateUiSyncEvent(specificSyncEventId?: string, toolId?: string): void
Returns - void
Defined in
- core/frontend/src/tools/ToolAdmin.ts Line 1673
Last Updated: 30 November, 2023