Name |
Description |
|
BatchOptions |
Options used when constructing a Batch - that is, a RenderGraphic with an associated FeatureTable describing individual Features within the |
|
CanvasDecoration |
A Decoration that is drawn onto the |
|
ComputeChordToleranceArgs |
Arguments used to compute the chord tolerance (level of detail) of the RenderGraphics produced by a GraphicBuilder. |
|
CreateRenderMaterialArgs |
Arguments supplied to RenderSystem.createRenderMaterial. |
|
CreateTextureArgs |
Arguments supplied to RenderSystem.createTexture to create a RenderTexture. |
|
CreateTextureFromSourceArgs |
Arguments supplied to RenderSystem.createTextureFromSource. |
|
CustomGraphicBuilderOptions |
Options for creating a GraphicBuilder to produce a RenderGraphic that is not associated with any particular Viewport and may not be associated with |
|
EdgeParams |
Describes the edges of a mesh. |
|
EdgeTableInfo |
|
|
GltfMeshPrimitive |
A unit of geometry belonging to a GltfMesh. |
|
GltfNodeBaseProps |
Properties common to Gltf1Node and Gltf2Node. |
|
GltfTextureInfo |
Describes a reference to a GltfTexture. |
|
GraphicArc |
A GraphicPrimitive representing a 3d open arc or closed ellipse that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicArc2d |
A GraphicPrimitive representing a 2d open arc or closed ellipse that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicBranchOptions |
Options passed to RenderSystem.createGraphicBranch. |
|
GraphicBuilderOptions |
Options for creating a GraphicBuilder used by functions like DecorateContext.createGraphic and RenderSystem.createGraphic. |
|
GraphicLineString |
A GraphicPrimitive representing a line string that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicLineString2d |
A GraphicPrimitive representing a 2d line string that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicLoop |
A GraphicPrimitive representing a 3d planar region that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicPath |
A GraphicPrimitive representing a 3d open path that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicPointString |
A GraphicPrimitive representing a point string that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicPointString2d |
A GraphicPrimitive representing a 2d point string that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicPolyface |
A GraphicPrimitive representing a mesh that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicPrimitive2d |
Base interface for a 2d GraphicPrimitive that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicShape |
A GraphicPrimitive representing a closed 3d planar region that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicShape2d |
A GraphicPrimitive representing a closed 2d region that can be supplied to GraphicBuilder.addPrimitive. |
|
GraphicSolidPrimitive |
A GraphicPrimitive representing a SolidPrimitive to be supplied to GraphicBuilder.addPrimitive. |
|
MaterialDiffuseProps |
Describes the diffuse properties of a RenderMaterial. |
|
MaterialSpecularProps |
Describes the specular properties of a material. |
|
MaterialTextureMappingProps |
Describes how to map a RenderTexture's image to the surfaces to which a RenderMaterial is applied. |
|
MeshArgs |
|
|
ParticleCollectionBuilder |
Interface for producing a collection of particles suitable for use in particle effects. |
|
ParticleCollectionBuilderParams |
Parameters used to construct a ParticleCollectionBuilder. |
|
ParticleProps |
Describes a particle to to add to a particle collection via ParticleCollectionBuilder.addParticle. |
|
PickableGraphicOptions |
Options used as part of GraphicBuilderOptions to describe a pickable RenderGraphic. |
|
PointCloudArgs |
|
|
PolylineArgs |
|
|
QueryScreenFeaturesOptions |
Options specifying how to query for visible Features by reading pixels rendered by a Viewport. |
|
QueryTileFeaturesOptions |
Options specifying how to query for visible Features by inspecting the Tiles selected for display by a Viewport. |
|
RealityMeshParams |
Geometry for a reality mesh to be submitted to the RenderSystem for conversion to a RenderGraphic. |
Beta |
RealityMeshParamsBuilderOptions |
Options used to construct a RealityMeshParamsBuilder. |
Beta |
RenderSystemDebugControl |
An interface optionally exposed by a RenderSystem that allows control of various debugging features. |
Beta |
ScreenSpaceEffectBuilder |
An interface used to construct and register with the IModelApp.renderSystem a custom screen-space effect. |
|
ScreenSpaceEffectBuilderParams |
Parameters used to create a ScreenSpaceEffectBuilder. |
|
ScreenSpaceEffectContext |
Context passed to ScreenSpaceEffectBuilder.shouldApply. |
|
ScreenSpaceEffectSource |
The GLSL implementation of the effect produced by a ScreenSpaceEffectBuilder, to be integrated into a complete shader program. |
|
SplitMeshArgs |
|
|
SplitPointStringArgs |
|
|
SplitPolylineArgs |
|
|
SplitVertexTableArgs |
|
|
TextureCacheOwnership |
Specifies that a RenderTexture should be kept in memory until the corresponding IModelConnection is closed, at |
|
TextureImage |
Describes the image from which to create a RenderTexture. |
|
Uniform |
Represents a uniform variable in a shader program used by a custom screen-space effect, providing methods for setting the current value of the uniform. |
|
UniformArrayParams |
Parameters used to define an array of uniform variables for a ScreenSpaceEffectBuilder's shader program. |
|
UniformContext |
Context supplied to UniformParams.bind. |
|
UniformParams |
Parameters used to define a uniform variable for a ScreenSpaceEffectBuilder's shader program. |
|
UpsampledRealityMeshParams |
|
|
ViewportGraphicBuilderOptions |
Options for creating a GraphicBuilder to produce a RenderGraphic to be displayed in a specific Viewport. |
|
VisibleFeature |
Represents a Feature determined to be visible within a Viewport. |
|