constructor Method
Create a new HitDetail from the inputs to and results of a locate operation.
HitDetail(testPoint: Point3d, viewport: ScreenViewport, hitSource: HitSource, hitPoint: Point3d, sourceId: string, priority: HitPriority, distXY: number, distFraction: number, subCategoryId?: string, geometryClass?: GeometryClass, modelId?: string, iModel?: IModelConnection, tileId?: string, isClassifier?: boolean): HitDetail
Parameter | Type | Description |
---|---|---|
testPoint | Point3d | The world coordinate space point that was used as the locate point. |
viewport | ScreenViewport | The view the locate operation was performed in. |
hitSource | HitSource | The procedure that requested the locate operation. |
hitPoint | Point3d | The approximate world coordinate location on the geometry identified by this HitDetail. |
sourceId | string | The source of the geometry, either a persistent element id or pickable decoration id. |
priority | HitPriority | The hit geometry priority/classification. |
distXY | number | The xy distance to hit in view coordinates. |
distFraction | number | The near plane distance fraction to hit. |
subCategoryId | string | The SubCategory for a persistent element hit. |
geometryClass | GeometryClass | The GeometryClass for a persistent element hit. |
modelId | string | Optionally the Id of the ModelState from which the hit originated. |
iModel | IModelConnection | The IModelConnection from which the hit originated. This should almost always be left undefined, unless the hit is known to have originated from an iModel other than the one associated with the viewport. |
tileId | string | Optionally the Id of the Tile from which the hit originated. |
isClassifier | boolean | Optionally whether the hit originated from a reality model classification. |
Returns - HitDetail
Defined in
- core/frontend/src/HitDetail.ts Line 137
Last Updated: 30 November, 2023