Symbology
Types that define the appearance of geometry.
Classes
Name | Description | |
---|---|---|
ColorDef | An immutable integer representation of a color. | |
FontMap | A FontMap holds the set of font names available in an iModel. | |
GeometryParams | Describes the display properties of graphics in a persistent element's GeometryStream that aren't inherited from SubCategoryAppearance. | |
GraphicParams | The "cooked" material and symbology for a RenderGraphic. | |
HSLColor | An immutable color defined by Hue, Saturation, and Lightness. | |
HSVColor | An immutable color defined by Hue, Saturation, and Value | |
RgbColor | An immutable representation of a color with red, green, and blue components each in the integer range [0, 255]. | |
SubCategoryAppearance | Parameters that define the way geometry on a SubCategory appears. | |
ThematicDisplay | The thematic display setup of a DisplayStyle3d. | |
ThematicDisplaySensor | A sensor in world space, used for ThematicDisplayMode.InverseDistanceWeightedSensors. | |
ThematicDisplaySensorSettings | Settings for sensor-based thematic display for ThematicDisplayMode.InverseDistanceWeightedSensors. | |
ThematicGradientSettings | Thematic settings specific to creating a color gradient used by ThematicDisplay. |
Constants
Name | Description | |
---|---|---|
ColorByName | A set of known colors by HTML color name, as a 32-bit integer in the form 0xBBGGRR (red is the low byte). |
Enumerations
Name | Description | |
---|---|---|
BackgroundFill | Describes how a view's background color affects the interior area of a closed region. | |
FillDisplay | Whether a closed region should be drawn for wireframe display with its internal area filled or not. | |
FillFlags | Flags indicating whether and how the interiors of closed planar regions is displayed within a view. | |
FontType | The type of a font. | |
GeometryClass | Categorizes a piece of geometry within a GeometryStream. | |
HSVConstants | ||
LinePixels | Enumerates the available patterns for drawing patterned lines. | |
ThematicDisplayMode | The thematic display mode. | |
ThematicGradientColorScheme | A color scheme used to generate the colors of a thematic gradient within an applied range. | |
ThematicGradientMode | A thematic gradient mode used to generate and apply a thematic effect to a scene. |
Interfaces
Name | Description | |
---|---|---|
FontMapProps | The properties of a FontMap | |
FontProps | The properties of a Font. | |
RgbColorProps | JSON representation of an RgbColor, with each component an integer in the range [0, 255]. | |
ThematicDisplayProps | JSON representation of the thematic display setup of a DisplayStyle3d. | |
ThematicDisplaySensorProps | JSON representation of a ThematicDisplaySensor. | |
ThematicDisplaySensorSettingsProps | JSON representation of a ThematicDisplaySensorSettings for ThematicDisplayMode.InverseDistanceWeightedSensors. | |
ThematicGradientSettingsProps | JSON representation of a ThematicGradientSettings. |
Namespaces
Name | Description | |
---|---|---|
AreaPattern | ||
Gradient | Namespace containing types for defining a color gradient, often used for filled planar regions. | |
LineStyle | ||
SubCategoryAppearance |
Type Aliases
Name | Description | |
---|---|---|
ColorDefProps | The JSON representation of a ColorDef - an unsigned 32-bit integer in 0xTTBBGGRR format. | |
FontId | An iModel-local identifier for a font. |
Last Updated: 21 November, 2022