setUsePrimaryConnection Method

Force a query to be executed synchronously against primary connection. This option is ignored if provided by frontend.

setUsePrimaryConnection(val: boolean): QueryOptionsBuilder

Parameter Type Description
val boolean A boolean value to force use primary connection on main thread to execute query.

Returns - QueryOptionsBuilder

@type QueryOptionsBuilder for fluent interface.

Defined in

Last Updated: 30 November, 2023