Geometry
Types for working with geometry.
Classes
Name | Description | |
---|---|---|
AdditionalTransform | Additional Transform implementation. | |
AffineTransform | The equations are: | |
BoundingSphere | Describes a spherical volume of space as an approximation of the shape of some more complex geometric entity fully contained within that volume. | |
Carto2DDegrees | A 2D cartographic point in degrees | |
Cartographic | A position on the earth defined by longitude, latitude, and height above the WGS84 ellipsoid. | |
CartographicRange | A cartographic range representing a rectangular region if low longitude/latitude > high then area crossing seam is indicated. | |
FrustumPlanes | Represents a the planes of a Frustum for testing containment and intersection. | |
GeocentricTransform | This class represents a geocentric (three parameters) geodetic transformation. | |
GeodeticDatum | This class represents a geodetic datum. | |
GeodeticEllipsoid | This class defines the mathematical model of the Earth shape in the form of an ellipsoid. | |
GeodeticTransform | This class represents a geodetic transformation that enables transforming longitude/latitude coordinates | |
GeodeticTransformPath | This class represents a geodetic datum transform path. | |
GeographicCRS | Geographic Coordinate Reference System implementation. | |
GeometryStreamBuilder | GeometryStreamBuilder is a helper class for populating the GeometryStreamProps array needed to create a GeometricElement or GeometryPart. | |
GeometryStreamIterator | GeometryStreamIterator is a helper class for iterating a GeometryStreamProps. | |
GridFileDefinition | Grid file definition containing name of the file, the format and the direction it should be applied | |
GridFileTransform | This class represents a grid files based geodetic transformation. | |
Helmert2DWithZOffset | An affine transformation with an additional Z Offset. | |
HorizontalCRS | Horizontal Geographic Coordinate reference System implementation. | |
HorizontalCRSExtent | The extent in latitude, longitude bounds where a horizontal CRS is applicable | |
ImageGraphic | A geometric primitive that displays an image mapped to the corners of a quadrilateral, with an optional border. | |
ImageGraphicCorners | Defines the 4 corners of an ImageGraphic. | |
Placement2d | The placement of a GeometricElement2d. | |
Placement3d | The placement of a GeometricElement3d. | |
PositionalVectorTransform | This class represents a positional vector (seven parameters) geodetic transformation corresponding to | |
Projection | This class encapsulates the projection of the CRS. | |
QParams2d | Parameters used for QParams2d.Quantization of 2d points such that the x and y components are each quantized to 16-bit unsigned integers. |
|
QParams3d | Parameters used for QParams3d.Quantization of 3d points such that the x , y , and z components are each quantized to 16-bit unsigned integers. |
|
QPoint2d | Represents a Point2d compressed such that each component x and y is quantized to the 16-bit integer range [0, 0xffff]. |
|
QPoint2dBufferBuilder | Constructs a QPoint2dBuffer using a Uint16ArrayBuilder. | |
QPoint2dList | A list of QPoint2ds all quantized to the same range. | |
QPoint3d | Represents a Point3d compressed such that each component x , y , and z is quantized to the 16-bit integer range [0, 0xffff]. |
|
QPoint3dBufferBuilder | Constructs a QPoint3dBuffer using a Uint16ArrayBuilder. | |
QPoint3dList | A list of QPoint3ds all quantized to the same range. | |
TextString | A single line of text, all with the same font, styles (underline, bold, italic), and size. | |
VerticalCRS | Vertical Coordinate reference System implementation. | |
XyzRotation | Hold 3 components data of a Positional Vector rotation definition in arc seconds |
Enumerations
Name | Description | |
---|---|---|
ElementGeometryOpcode | Specifies the type of an entry in a geometry stream. | |
GeometryStreamFlags | Flags applied to the entire contents of a GeometryStreamProps. | |
GeometrySummaryVerbosity | Describes the level of detail with which to report each geometric primitive in a GeometrySummaryRequestProps. | |
MassPropertiesOperation | Specify whether to accumulate volumes, areas, or lengths for the supplied elements. |
Global Functions
Name | Description | |
---|---|---|
readElementMeshes | Convert the output of IModelConnection.generateElementMeshes into an array of Polyfaces. | Beta |
Interfaces
Name | Description | |
---|---|---|
AdditionalTransformProps | Additional Transform definition | |
AffineTransformProps | The equations are: | |
AreaFillProps | Add a AreaFillProps.gradient, AreaFillProps.backgroundFill, or solid AreaFillProps.color fill to subsequent planar regions (or meshes). | |
BRepPrimitive | Represents a BRep within a GeometryStream. | |
Carto2DDegreesProps | A 2D cartographic point in degrees | |
CartographicProps | The JSON representation of a Cartographic object. | |
DeletedElementGeometryChange | Represents the deletion of a GeometricElement. | |
ElementGeometryDataEntry | Describes an entry in a geometry stream as an op-code plus the binary flatbuffer representation of the associated data. | |
ElementIdsAndRangesProps | Compact wire format representing geometric changes to a set of elements as part of a ModelGeometryChangesProps. | |
ElementMeshOptions | Options used to control how Polyfaces are produced from elements by IModelConnection.generateElementMeshes. | Beta |
ElementMeshRequestProps | Describes a request to generate Polyfaces from an element. | Beta |
ExtantElementGeometryChange | Represents the insertion of a new GeometricElement, or a change to the geometric properties of an existing GeometricElement. | |
GeocentricTransformProps | This interface represents a geocentric (three parameters) geodetic transformation. | |
GeodeticDatumProps | This interface represents a geodetic datum. | |
GeodeticEllipsoidProps | This interface defines the mathematical model of the Earth shape in the form of an ellipsoid. | |
GeodeticTransformPathProps | This interface represents a geodetic datum transform path. | |
GeodeticTransformProps | This interface represents a geodetic transformation that enables transforming longitude/latitude coordinates | |
GeographicCRSProps | Geographic Coordinate Reference System definition that includes the horizontal and vertical definitions as well as an optional | |
GeometryAppearanceProps | Establish a non-default SubCategory or to override SubCategoryAppearance for the geometry that follows. | |
GeometryContainmentRequestProps | Information required to request clip containment status for elements from the front end to the back end. | |
GeometryContainmentResponseProps | Information returned from the back end to the front end holding the result of the geometry containment query. | |
GeometryPartInstanceProps | Add a reference to a GeometryPart from the GeometryStream of a GeometricElement. | |
GeometryPrimitive | Represents one of a variety of GeometryQuery objects within a GeometryStream. | |
GeometryStreamEntryProps | Allowed GeometryStream entries - should only set one value. | |
GeometryStreamHeaderProps | An entry in a GeometryStreamProps containing GeometryStreamFlags that apply to the geometry stream as a whole. | |
GeometryStreamIteratorEntry | Holds current state information for GeometryStreamIterator. | |
GeometrySummaryOptions | Describes what information to include in a GeometrySummaryRequestProps. | |
GeometrySummaryRequestProps | Describes the elements for which to generate an array of geometry summaries and the options controlling the contents of each summary. | |
GridFileDefinitionProps | Grid file definition containing name of the file, the format and the direction it should be applied | |
GridFileTransformProps | This interface represents a grid files based geodetic transformation. | |
Helmert2DWithZOffsetProps | An affine transformation with an additional Z Offset. | |
HorizontalCRSExtentProps | The extent in latitude, longitude bounds where a horizontal CRS is applicable | |
HorizontalCRSProps | Horizontal Geographic Coordinate Reference System definition | |
ImageGraphicProps | JSON representation of an ImageGraphic. | |
ImagePrimitive | Represents an image within a GeometryStream. | |
MassPropertiesPerCandidateRequestProps | Information required to request mass properties for each element separately from the front end to the back end. | |
MassPropertiesPerCandidateResponseProps | Information returned from the back end to the front end holding the result of the mass properties calculation for a single candidate. | |
MassPropertiesRequestProps | Information required to request mass properties for elements from the front end to the back end. | |
MassPropertiesResponseProps | Information returned from the back end to the front end holding the result of the mass properties calculation. | |
MaterialProps | Override SubCategoryAppearance.materialId for subsequent surface and solid geometry. | |
ModelGeometryChanges | Represents geometric changes to a set of GeometricElements belonging to a single GeometricModel. | |
ModelGeometryChangesProps | Compact wire format representing geometric changes to GeometricElements within a GeometricModel. | |
PartReference | Represents a reference to a GeometryPart within a GeometryStream. | |
PositionalVectorTransformProps | This interface represents a positional vector (seven parameters) geodetic transformation corresponding to | |
ProjectionProps | This class encapsulates the projection of the CRS. | |
QPoint2dBuffer | A compact representation of a list of QPoint2ds stored in a Uint16Array |
|
QPoint3dBuffer | A compact representation of a list of QPoint3ds stored in a Uint16Array . |
|
TextStringPrimitive | Represents a text string within a GeometryStream. | |
TextStringProps | Properties for a TextString class. | |
VerticalCRSProps | Vertical Geographic Coordinate reference System definition | |
XyzRotationProps | Holds 3 components of a Positional Vector rotation definition in arc seconds |
Namespaces
Name | Description | |
---|---|---|
BRepEntity | JSON representation of a brep GeometryStream entry. | |
ElementGeometryChange | Represents a change to the geometry of a GeometricElement, as exposed by ModelGeometryChanges.elements. | |
FrustumPlanes | ||
ModelGeometryChanges | Represents geometric changes to a set of GeometricElements belonging to a single GeometricModel. | |
QPoint2dBuffer | ||
QPoint3dBuffer | ||
Quantization | Provides facilities for quantizing floating point values within a specified range into 16-bit unsigned integers. |
Type Aliases
Name | Description | |
---|---|---|
AxisAlignedBox3d | A Range3d that is aligned with the axes of spatial coordinates. | |
AxisAlignedBox3dProps | The properties of a Range3d. | |
DanishSystem34Region | The type to define the three zones of the Danish System 34 projections. | |
ElementAlignedBox2d | A bounding box aligned to the orientation of a 2d Element | |
ElementAlignedBox3d | A bounding box aligned to the orientation of a 3d Element | |
ElementGeometryChange | ||
GeodeticTransformMethod | Type indicating the geodetic transformation method | |
GeometryStreamPrimitive | Union of all possible geometric primitive types that may appear within a GeometryStream. | |
GeometryStreamProps | A GeometricElement's GeometryStream is represented by an array of GeometryStreamEntryProps. | |
GridFileDirection | type to indicate the grid file application direction. | |
GridFileFormat | Type indicating the file format of the grid files. | |
HemisphereEnum | Type used in the definition of UTM Zoning projection. | |
ImageGraphicCornersProps | JSON representation of the 4 corners of an ImageGraphicProps. | |
LocalAlignedBox3d | A bounding box aligned to a local coordinate system | |
Placement | Either a Placement2d or Placement3d | |
ProjectionMethod | This enum contains the list of all projection methods that can be represented as part of the HorizontalCRS | |
UnitType | This type indicates possible linear and angular units supported. |
Last Updated: 30 November, 2023