WorkspaceCloudCacheProps Interface
Beta
The properties of the CloudCache used for Workspaces.
Extends
- Optional<CloudSqlite.CacheProps, "name" | "rootDir">
Properties
Name | Type | Description | |
---|---|---|---|
clearContents | undefined | boolean | if true, empty the cache before using it. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
cacheSize | undefined | string | Optional | maximum cache Size. |
curlDiagnostics | undefined | boolean | Optional | turn on diagnostics for curl (outputs to stderr) |
nRequests | undefined | number | Optional | The number of simultaneous HTTP requests. |
name | undefined | string | Optional | name of this cache. |
rootDir | undefined | string | Optional | full path of directory for cache to store its files. |
Defined in
- backend/src/workspace/Workspace.ts Line 186
Last Updated: 30 November, 2023