LineStyleDefinition.StrokePointProps Interface
Stroke point component definition LineStyleDefinition.ComponentType.StrokePoint. A stroke point component identifies the locations of point symbol components relative to a base stroke pattern component.
Properties
Name | Type | Description | |
---|---|---|---|
descr | string | Name for this stroke point component | |
lcId | number | The file property id of the stroke component, assumed to be LineStyleDefinition.ComponentType.StrokePattern if lcType is undefined | |
lcType | undefined | LineStyleDefinition.ComponentType | The component type, leave undefined if lcId is a LineStyleDefinition.ComponentType.StrokePattern | |
symbols | LineStyleDefinition.Symbols | Array of symbols |
Defined in
- backend/src/LineStyle.ts Line 230
Last Updated: 30 November, 2023