LineStyleDefinition.StrokeMode Enumeration
Mask of values for StrokeMode
Members
Name | Value | Description |
---|---|---|
Gap | 0 | Stroke represents a blank space |
Dash | 1 | Stroke represents a solid dash |
Ray | 2 | Treat stroke as rigid and continue past a corner to complete the stroke as opposed to breaking at the corner |
Scale | 4 | Stroke length can be stretched when LineStyleDefinition.StrokePatternOptions.Iteration and LineStyleDefinition.StrokePatternOptions.AutoPhase options are set, applicable to both Gap and Dash strokes |
FirstInvert | 8 | Invert stroke in first stroke pattern |
LastInvert | 16 | Invert stroke in last stroke pattern |
Defined in
- backend/src/LineStyle.ts Line 43
Last Updated: 30 November, 2023