LineStyleDefinition.ComponentProps Interface
Identifies a component by file property id and type
Properties
Name | Type | Description | |
---|---|---|---|
id | number | The file property id of LineStyleDefinition.ComponentType.StrokePattern or LineStyleDefinition.ComponentType.StrokePoint component | |
offset | undefined | number | Offset distance for this component, default is 0 | |
type | LineStyleDefinition.ComponentType | The type of component for specified file property id |
Defined in
- backend/src/LineStyle.ts Line 260
Last Updated: 30 November, 2023