beginMultiTxnOperation Method
Begin a new multi-Txn operation. This can be used to cause a series of Txns that would normally be considered separate actions for undo to be grouped into a single undoable operation. This means that when reverseTxns(1) is called, the entire group of changes are undone together. Multi-Txn operations can be nested and until the outermost operation is closed all changes constitute a single operation.
beginMultiTxnOperation(): DbResult
note This method must always be paired with a call to endMultiTxnAction.
Returns - DbResult
Defined in
- backend/src/TxnManager.ts Line 379
Last Updated: 30 November, 2023