checkExclusiveLock Method
Throw if locks are required and the exclusive lock is not held on the supplied element. Note: there is no need to check the shared locks on parents/models since an element cannot hold the exclusive lock without first obtaining them. Called by Element.onUpdate, Element.onDelete, etc.
checkExclusiveLock(id: string, type: string, operation: string): void
internal
Parameter | Type | Description |
---|---|---|
id | string | |
type | string | |
operation | string |
Returns - void
Last Updated: 30 November, 2023