iModels
Classes for working with iModels. See the learning article.
Classes
Name | Description | |
---|---|---|
BriefcaseDb | A local copy of an iModel from iModelHub that can pull and potentially push changesets. | |
BriefcaseManager | Manages downloading Briefcases and downloading and uploading changesets. | |
ChangeSummaryManager | Class to extract Change Summaries for a briefcase. | Beta |
ExportGraphicsMeshVisitor | * Iterator to walk the facets of an ExportGraphicsMesh and present them to the world as if visiting a Polyface. | |
IModelDb | An iModel database file. | |
IModelElementCloneContext | The context for transforming a source Element to a target Element and remapping internal identifiers to the target iModel. | Beta |
SnapshotDb | A snapshot iModel database file that is used for archival and data transfer purposes. | |
StandaloneDb | Standalone iModels are read/write files that are not associated with an iTwin or managed by iModelHub. | |
TxnManager | Manages local changes to a BriefcaseDb or StandaloneDb via Txns |
Constants
Name | Description | |
---|---|---|
IModelCloneContext | Deprecated |
Enumerations
Name | Description | |
---|---|---|
ProgressStatus | Return value from ProgressFunction. |
Global Functions
Name | Description | |
---|---|---|
setMaxEntitiesPerEvent | Strictly for tests. |
Interfaces
Name | Description | |
---|---|---|
ChangeSummary | Represents an instance of the ChangeSummary ECClass from the ECDbChange ECSchema |
Beta |
ChangeSummaryExtractOptions | Options for ChangeSummaryManager.extractChangeSummaries. | Beta |
CheckpointProps | Properties of a checkpoint | |
CloudContainerArgs | Augments a SnapshotDbOpenArgs or OpenBriefcaseArgs with a CloudContainer. | |
ComputedProjectExtents | The result of IModelDb.computeProjectExtents. | |
ComputeProjectExtentsOptions | Options supplied to IModelDb.computeProjectExtents. | |
CreateChangeSummaryArgs | Options for ChangeSummaryManager.createChangeSummaries. | Beta |
ExportGraphicsInfo | Info provided to ExportGraphicsFunction about graphics. | |
ExportGraphicsLines | A collection of line segments, suitable for direct use with graphics APIs. | |
ExportGraphicsMesh | A triangulated mesh with unified indices, suitable for direct use with graphics APIs. | |
ExportGraphicsOptions | Parameters for IModelDb.exportGraphics | |
ExportLinesInfo | Info provided to ExportLinesFunction about linework graphics. | |
ExportPartDisplayInfo | Information about the base display properties when a GeometryPart was | |
ExportPartGraphicsOptions | Parameters for IModelDb.exportPartGraphics | |
ExportPartInfo | Info provided to ExportPartFunction about graphics. | |
ExportPartInstanceInfo | Information about references to GeometryPart elements found during | |
ExportPartLinesInfo | Info provided to ExportPartFunction about line graphics. | |
InstanceChange | Represents an instance of the InstanceChange ECClass from the ECDbChange ECSchema |
Beta |
LockControl | Interface for acquiring element locks to coordinate simultaneous edits from multiple briefcases. | Beta |
PushChangesArgs | Parameters for pushing changesets to iModelHub | |
RequestNewBriefcaseArg | The argument for BriefcaseManager.downloadBriefcase | |
SchemaImportOptions | Options for the importing of schemas | |
ToChangesetArgs | Specifies a specific index for pulling changes. | |
TokenArg | Argument to a function that can accept a valid access token. | |
TxnChangedEntities | Describes a set of Elements or Models that changed as part of a transaction. | |
UpdateModelOptions | Options for IModelDb.Models.updateModel | |
ValidationError | An error generated during dependency validation. |
Namespaces
Name | Description | |
---|---|---|
ExportGraphics | Provides utility functions for working with data generated by IModelDb.exportGraphics | |
IModelDb |
Type Aliases
Name | Description | |
---|---|---|
ExportGraphicsFunction | ||
ExportLinesFunction | ||
ExportPartFunction | ||
ExportPartLinesFunction | ||
IModelCloneContext | Deprecated | |
OpenBriefcaseArgs | Arguments to open a BriefcaseDb | |
ProgressFunction | ||
PullChangesArgs | Arguments for BriefcaseManager.pullAndApplyChangesets | |
SnapshotDbOpenArgs | Options to open a SnapshotDb. | |
TxnIdString | A string that identifies a Txn. |
Last Updated: 30 November, 2023