deleteElementSubTrees Function
Beta
Deletes all element sub-trees that are selected by the supplied filter. Uses ElementSubTreeDeleter. If the filter selects the top element itself, then the entire tree (including the top element) is deleted. That has the same effect as calling deleteElementTree on the top element.
deleteElementSubTrees(iModel: IModelDb, topElement: string, filter: ElementSubTreeDeleteFilter): void
Parameter | Type | Description |
---|---|---|
iModel | IModelDb | The iModel |
topElement | string | Where to start the search. |
filter | ElementSubTreeDeleteFilter | Callback that selects sub-trees that should be deleted. |
Returns - void
Defined in
- backend/src/ElementTreeWalker.ts Line 464
Last Updated: 30 November, 2023