ElementAspects
Subclasses of ElementAspects.
See the learning articles.
Classes
Name |
Description |
|
ChannelRootAspect |
A ChannelRootAspect identifies an Element as the root of a channel which is a subset of the overall iModel hierarchy that is independently maintained. |
|
ElementAspect |
An Element Aspect is a class that defines a set of properties that are related to (and owned by) a single element. |
|
ElementMultiAspect |
An Element Multi-Aspect is an ElementAspect where there can be n instances of the Element Aspect class per Element. |
|
ElementUniqueAspect |
An Element Unique Aspect is an ElementAspect where there can be only zero or one instance of the Element Aspect class per Element. |
|
ExternalSourceAspect |
An ElementMultiAspect that stores synchronization information for an Element originating from an external source. |
|
Interfaces
Name |
Description |
|
OnAspectArg |
Argument for the ElementAspect.onXxx static methods |
Beta |
OnAspectIdArg |
Argument for the ElementAspect.onXxx static methods that only supply the Id of the affected aspect. |
Beta |
OnAspectPropsArg |
Argument for the ElementAspect.onXxx static methods that supply the properties of an aspect to be inserted or updated. |
Beta |
Namespaces
Last Updated:
30 November, 2023