DragDrop
Classes and Higher Order Components for working with the DragDrop API.
Enumerations
Name |
Description |
|
DropEffects |
Enum for different DropEffects. |
Beta |
DropStatus |
Enum for status of current drag/drop item |
Beta |
Global Functions
Name |
Description |
|
BeDragDropContext |
Context component for DragDrop API. |
Beta |
withDragSource |
HOC (Higher-Order Component) that transforms wrapped component into a DragSource. |
Beta |
withDropTarget |
HOC (Higher-Order Component) that transforms wrapped component into a DropTarget. |
Beta |
Interfaces
Name |
Description |
|
DragDropArguments |
Base DragDropArguments interface, used by both DragSourceArguments and DragTargetArguments. |
Beta |
DragLayerProps |
Properties for DragLayer components |
Beta |
DragSourceArguments |
Interface for arguments supplied to DragSource callbacks, including onDragSourceBegin, and onDragSourceEnd, as well as to the DragLayers as a prop. |
Beta |
DragSourceProps |
Properties and callbacks for the withDragSource Higher-Order Component. |
Beta |
DropTargetArguments |
Interface for arguments supplied to DropTarget callbacks, including onDropTargetOver, onDropTargetDrop, and canDropTargetDrop. |
Beta |
DropTargetProps |
Properties and callbacks for the withDragSource Higher-Order Component. |
Beta |
WithDragSourceProps |
React properties for withDragSource Higher-Order Component |
Beta |
WithDropTargetProps |
React properties for withDropTarget Higher-Order Component |
Beta |
Last Updated:
29 September, 2021