initialize MethodStatic
Overloads | |
---|---|
initialize(store, frameworkStateKey?) Static | |
initialize(store, frameworkStateKey?, startInUi1Mode?) Static | Deprecated |
initialize(store, frameworkStateKey?)
Called by the application to initialize the UiFramework. Also initializes UIIModelComponents, UiComponents, UiCore.
initialize(store: undefined | Store<any, AnyAction>, frameworkStateKey?: string): Promise<void>
Parameter | Type | Description |
---|---|---|
store | undefined | Store<any, AnyAction> | The single Redux store created by the host application. If this is undefined then it is assumed that the StateManager is being used to provide the Redux store. |
frameworkStateKey | string | The name of the key used by the app when adding the UiFramework state into the Redux store. If not defined "frameworkState" is assumed. This value is ignored if StateManager is being used. The StateManager use "frameworkState". |
Returns - Promise<void>
initialize(store, frameworkStateKey?, startInUi1Mode?)
Deprecated in 3.5. UI1.0 is deprecated. Use an overload without a startInUi1Mode
argument instead.
Called by the application to initialize the UiFramework. Also initializes UIIModelComponents, UiComponents, UiCore.
initialize(store: undefined | Store<any, AnyAction>, frameworkStateKey?: string, startInUi1Mode?: boolean): Promise<void>
Parameter | Type | Description |
---|---|---|
store | undefined | Store<any, AnyAction> | The single Redux store created by the host application. If this is undefined then it is assumed that the StateManager is being used to provide the Redux store. |
frameworkStateKey | string | The name of the key used by the app when adding the UiFramework state into the Redux store. If not defined "frameworkState" is assumed. This value is ignored if StateManager is being used. The StateManager use "frameworkState". |
startInUi1Mode | boolean | Used for legacy applications to start up in the deprecated UI 1 mode. This should not set by newer applications. |
Returns - Promise<void>
Defined in
Last Updated: 30 November, 2023