ModelsTreeProps Interface
Deprecated in 3.6. Was moved to @itwin/tree-widget-react
package.
Props for ModelsTree component
Methods
Name | Description | |
---|---|---|
onFilterApplied(filteredDataProvider: IPresentationTreeDataProvider, matchesCount: number): void Optional | Callback invoked when tree is filtered. |
Properties
Name | Type | Description | |
---|---|---|---|
activeView | undefined | Viewport | Active view used to determine and control visibility | |
enableElementsClassGrouping | undefined | ClassGroupingOption | Should the tree group displayed element nodes by class. | Beta |
enableHierarchyAutoUpdate | undefined | boolean | Auto-update the hierarchy when data in the iModel changes. | |
filterInfo | undefined | | Information for tree filtering. | |
filteredElementIds | undefined | Id64Array | Filter the hierarchy by given element IDs. | |
height | number | Height of the component | |
iModel | IModelConnection | An IModel to pull data from | |
modelsVisibilityHandler | undefined | | Custom visibility handler. | |
rootElementRef | undefined | Ref<HTMLDivElement> | Ref to the root HTML element used by this component | |
selectionMode | undefined | SelectionMode | Selection mode in the tree | |
selectionPredicate | undefined | ModelsTreeSelectionPredicate | Predicate which indicates whether node can be selected or no | |
width | number | Width of the component |
Defined in
Last Updated: 30 November, 2023