FrameworkDialog Interface
Beta
Manages dialog access
Methods
Name | Description | |
---|---|---|
close(dialog?: ReactNode): void | Close a modal dialog | |
open(dialog: ReactNode, id?: string, parentDocument?: Document): void | Open a modal dialog | |
update(): void | Update the dialogs |
Properties
Name | Type | Description | |
---|---|---|---|
active Readonly | ReactNode | Get the active modal dialog | |
count Readonly | number | Get the count of modal dialogs | |
dialogs Readonly | DialogInfo[] | Get the array of modal dialogs |
Defined in
Last Updated: 30 November, 2023