openDialog Method
Opens a Dialog and automatically populates it using the properties defined by the UiDataProvider.
openDialog(uiDataProvider: DialogLayoutDataProvider, title: string, isModal: boolean, id: string, optionalProps?: DialogProps): boolean
Parameter | Type | Description |
---|---|---|
uiDataProvider | DialogLayoutDataProvider | The UiDataProvider for the tool settings |
title | string | Specify title for dialog. |
isModal | boolean | Specify if the dialog is opened as a modal or modeless. |
id | string | Id of the dialog that is used to close it. |
optionalProps | DialogProps | Optional props for Dialog construction. |
Returns - boolean
true if the tool settings were displayed, false if the tool settings could not be displayed.
Defined in
Last Updated: 30 November, 2023