Properties
Properties system for data input and formatting.
Classes
Name | Description | |
---|---|---|
BaseQuantityDescription | Base Quantity Property Description | Beta |
PropertyDescriptionHelper | Helper class that builds property descriptions for specific PropertyEditors and processes descriptions. | |
PropertyRecord | PropertyRecord contains instance information about a Property, including a |
Enumerations
Name | Description | |
---|---|---|
AlternateDateFormats | Alternate Data Formats that can be provide by javascript. | |
PropertyEditorParamTypes | Enum for Property Editor Param Types | |
PropertyValueFormat | Enumeration for Format of the property value. | |
StandardEditorNames | Standard Editor Names for property editors. | |
StandardTypeNames | Standard Type Names for converters and editors. | |
TimeDisplay | Enum that defines supported time formats. |
Global Functions
Name | Description | |
---|---|---|
isButtonGroupEditorParams | ButtonGroupEditorParams type guard. | |
isColorEditorParams | ColorEditorParams type guard. | |
isCustomFormattedNumberParams | CustomFormattedNumberParams type guard. | |
isIconListEditorParams | IconListEditorParams type guard. | |
isInputEditorSizeParams | InputEditorSizeParams type guard. | |
isSuppressLabelEditorParams | SuppressLabelEditorParams type guard. |
Interfaces
Name | Description | |
---|---|---|
ArrayValue | Array property value | |
BasePropertyEditorParams | BasePropertyEditorParams Base interface for Property Editor Params | |
BasePropertyValue | Base interface for a property value | |
ButtonGroupEditorParams | ButtonGroupEditorParams Parameters used by EnumButtonGroupEditor to define icons in button group. | |
ColorEditorParams | ColorEditorParams Parameters used to populate color type editor with a specific set of colors. | |
CustomFormattedNumberParams | Parameters used with properties that want to control parsing and formatting. | |
DateFormatter | Interface used to provide a custom Date Time formatter and optional parser | |
EnumerationChoice | Information about an enumeration choice | |
EnumerationChoicesInfo | Information about a set of enumeration choices | |
IconDefinition | IconDefinition Information about an icon displayed next to a property editor. | |
IconEditorParams | Parameters used to display an icon next to property editor. | |
IconListEditorParams | IconListEditorParams Parameters used to populate icon type editor with a specific set of icons. | |
ImageCheckBoxParams | Parameters for ImageCheckBoxEditor | |
InputEditorSizeParams | InputEditorSizeParams type guard. | |
LinkElementsInfo | Properties for the PropertyRecord with link info supplied | |
MultilineTextEditorParams | Parameter that is used to indicate that a multiline text editor should be created. | |
ParseResults | defines Results of parsing a string input by a user into its desired value type | |
PrimitiveValue | Primitive property value | |
PropertyConverterInfo | Information about a Property Converter | |
PropertyDescription | PropertyDescription contains metadata about a Property | |
PropertyEditorInfo | Information about a Property Editor | |
PropertyRendererInfo | Property renderer identification and customization attributes | |
RangeEditorParams | Parameters used by PropertyEditors that support defining a minimum and maximum value. | |
SliderEditorParams | Parameters used to indicate that a Slider should be presented for the property | |
StructValue | Struct property value | |
SuppressLabelEditorParams | SuppressLabelEditorParams Parameters used to suppress the label for a type editor in the ToolSettings widget. |
Namespaces
Name | Description | |
---|---|---|
Primitives | Primitive Property Value Types. |
Type Aliases
Name | Description | |
---|---|---|
PropertyEditorParams | Type definition for Property Editor params | |
PropertyValue | Type for all property values |
Last Updated: 30 November, 2023