RenderTexture Namespace

Enumeration

Name Description
RenderTexture.Type The types of RenderTextures that can be created by a RenderSystem.

Class

Name Description
RenderTexture.Params Parameters used to construct a RenderTexture.

Defined in

RenderTexture Class

Represents a texture image applied to a surface during rendering. A RenderTexture is typically - but not always - associated with a RenderMaterial.

@see - RenderSystem.createTextureFromImage to obtain a texture from an HTML image.

Implements

  • Disposable

Methods

Name Description
constructor(type: RenderTexture.Type): RenderTexture Protected    
[dispose](): void Releases any WebGL resources owned by this texture.  
compare(other: RenderTexture): number An OrderedComparator that compares this texture against other.  
dispose(): void Abstract   Deprecated  

Properties

Name Type Description
bytesUsed Accessor Abstract ReadOnly number    
isGlyph Accessor ReadOnly boolean    
isSkyBox Accessor ReadOnly boolean    
isTileSection Accessor ReadOnly boolean    
type Readonly RenderTexture.Type Indicates the type of texture.  

Defined in

Last Updated: 23 January, 2025